// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)<t(d|r)>").unwrap();
let string = "<table><tr><td>Cell text</td></tr><tr>";
let substitution = "\\n<t\\1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}