re = /<t(d|r)>/
str = '<table><tr><td>Cell text</td></tr><tr>'
subst = '\\n<t\\1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result