#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!-|.*-$)[A-Za-z-]{2,}$"
Local $sString = "abcd" & @CRLF & _
"a-b-c-d" & @CRLF & _
"-a-b-c-d" & @CRLF & _
"a-b-c-d-" & @CRLF & _
"A-B" & @CRLF & _
"a-b" & @CRLF & _
"AA" & @CRLF & _
"aa" & @CRLF & _
"a" & @CRLF & _
"A" & @CRLF & _
"AAAAAAAAAAAAAAAAAA" & @CRLF & _
"BBBBBBBBBBBBBBBBBB" & @CRLF & _
"A--A" & @CRLF & _
"b--b" & @CRLF & _
"A-------b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")