$re = '/^(?!-|.*-$)[A-Za-z-]{2,}$/m';
$str = 'abcd
a-b-c-d
-a-b-c-d
a-b-c-d-
A-B
a-b
AA
aa
a
A
AAAAAAAAAAAAAAAAAA
BBBBBBBBBBBBBBBBBB
A--A
b--b
A-------b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);