import re
regex = re.compile(r"^(?!-|.*-$)[A-Za-z-]{2,}$", flags=re.MULTILINE)
test_str = ("abcd\n"
"a-b-c-d\n"
"-a-b-c-d\n"
"a-b-c-d-\n"
"A-B\n"
"a-b\n"
"AA\n"
"aa\n"
"a\n"
"A\n"
"AAAAAAAAAAAAAAAAAA\n"
"BBBBBBBBBBBBBBBBBB\n"
"A--A\n"
"b--b\n"
"A-------b\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")