re = /^(?!-|.*-$)[A-Za-z-]{2,}$/m
str = 'abcd
a-b-c-d
-a-b-c-d
a-b-c-d-
A-B
a-b
AA
aa
a
A
AAAAAAAAAAAAAAAAAA
BBBBBBBBBBBBBBBBBB
A--A
b--b
A-------b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end