# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\s+(\d+)\s+(\d+)/$1.$2/gm;t' <<< "$ 3 58"