$re = '/\$\s+(\d+)\s+(\d+)/m';
$str = '$ 3 58';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;