import re
regex = re.compile(r"\$\s+(\d+)\s+(\d+)", flags=re.MULTILINE)
test_str = "$ 3 58"
subst = "$1.$2"
result = regex.sub(subst, test_str)
if result:
print(result)