package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$\s+(\d+)\s+(\d+)`)
var str = `$ 3 58`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}