use strict;
my $str = '$ 3 58';
my $regex = qr/\$\s+(\d+)\s+(\d+)/mp;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";