#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?/(\w+)/([-a-z]+?)/?(?:\?.*?)*(?:\s|$)"
Local $sString = "http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/" & @CRLF & _
"http://www.test.com/location/newyork/training/?abc=1"
Local $sSubst = "http://www.test.com/location/$1/$2\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)