const regex = new RegExp('.*?/(\\w+)/([-a-z]+?)/?(?:\\?.*?)*(?:\\s|$)', 'gm')
const str = `http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1`;
const subst = `http://www.test.com/location/$1/$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);