import Foundation
let pattern = #".*?/(\w+)/([-a-z]+?)/?(?:\?.*?)*(?:\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://www.test.com/location/$1/$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)