# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?/(\w+)/([-a-z]+?)/?(?:\?.*?)*(?:\s|$)"
test_str = ("http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/\n"
"http://www.test.com/location/newyork/training/?abc=1")
subst = "http://www.test.com/location/$1/$2\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.