$re = '~.*?/(\w+)/([-a-z]+?)/?(?:\?.*?)*(?:\s|$)~m';
$str = 'http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1';
$subst = "http://www.test.com/location/$1/$2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;