using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?/(\w+)/([-a-z]+?)/?(?:\?.*?)*(?:\s|$)";
string substitution = @"http://www.test.com/location/$1/$2\n";
string input = @"http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}