using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(foo|bar)\d{2}";
string input = @"hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}