const regex = /(foo|bar)\d{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(foo|bar)\\d{2}', 'g')
const str = `hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}