re = /(foo|bar)\d{2}/
str = 'hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end