$re = '/(foo|bar)\d{2}/';
$str = 'hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);