// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(foo|bar)\d{2}").unwrap();
let string = "hello foo33 world bar12
bar66 something foo14
this one only has bar45
this one has neither";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}