# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*U([0-9]+)-S([0-9]+)-P([0-9]+)/0$1-0$2-0$3/gm;t' <<< "WS-S5-S-L1-C31-F-U5-S9-P14
WS-S5-S-L1-C31-F-U5-S8-P1
WS-S5-N-L1-C29-V-U16-S6-P6
"