import Foundation
let pattern = #".*U([0-9]+)-S([0-9]+)-P([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
WS-S5-S-L1-C31-F-U5-S9-P14
WS-S5-S-L1-C31-F-U5-S8-P1
WS-S5-N-L1-C29-V-U16-S6-P6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1-0$2-0$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)