using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*U([0-9]+)-S([0-9]+)-P([0-9]+)";
string substitution = @"0$1-0$2-0$3";
string input = @"WS-S5-S-L1-C31-F-U5-S9-P14
WS-S5-S-L1-C31-F-U5-S8-P1
WS-S5-N-L1-C29-V-U16-S6-P6
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}