re = /.*U([0-9]+)-S([0-9]+)-P([0-9]+)/m
str = 'WS-S5-S-L1-C31-F-U5-S9-P14
WS-S5-S-L1-C31-F-U5-S8-P1
WS-S5-N-L1-C29-V-U16-S6-P6
'
subst = '0$1-0$2-0$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result