const regex = /.*U([0-9]+)-S([0-9]+)-P([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*U([0-9]+)-S([0-9]+)-P([0-9]+)', 'gm')
const str = `WS-S5-S-L1-C31-F-U5-S9-P14
WS-S5-S-L1-C31-F-U5-S8-P1
WS-S5-N-L1-C29-V-U16-S6-P6
`;
const subst = `0$1-0$2-0$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);