#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*U([0-9]+)-S([0-9]+)-P([0-9]+)"
Local $sString = "WS-S5-S-L1-C31-F-U5-S9-P14 " & @CRLF & _
"WS-S5-S-L1-C31-F-U5-S8-P1 " & @CRLF & _
"WS-S5-N-L1-C29-V-U16-S6-P6" & @CRLF & _
""
Local $sSubst = "0$1-0$2-0$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)