#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?:\s+(.*?[!.?](?=\s)|[^"]*).*$"
Local $sString = "@user hey heres my message: first message: and a second colon! haha."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)