re = /^.*?:\s+(.*?[!.?](?=\s)|[^"]*).*$/m
str = '@user hey heres my message: first message: and a second colon! haha.'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result