use strict;
my $str = '@user hey heres my message: first message: and a second colon! haha.';
my $regex = qr~^.*?:\s+(.*?[!.?](?=\s)|[^"]*).*$~mp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";