const regex = new RegExp('^.*?:\\s+(.*?[!.?](?=\\s)|[^"]*).*$', 'gm')
const str = `@user hey heres my message: first message: and a second colon! haha.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);