$re = '~^.*?:\s+(.*?[!.?](?=\s)|[^"]*).*$~m';
$str = '@user hey heres my message: first message: and a second colon! haha.';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;