using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?:\s+(.*?[!.?](?=\s)|[^""]*).*$";
string substitution = @"\1";
string input = @"@user hey heres my message: first message: and a second colon! haha.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}