package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)MUST\s+(?:\(([^()]+)\)|(\S+))\s*(?:MAY)?`)
var str = `( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )
( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )
( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code $ name ) )
( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}