import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MUST\\s+(?:\\(([^()]+)\\)|(\\S+))\\s*(?:MAY)?";
final String string = "( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )\n\n"
+ "( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )\n\n"
+ "( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code $ name ) )\n\n"
+ "( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}