import re
regex = re.compile(r"MUST\s+(?:\(([^()]+)\)|(\S+))\s*(?:MAY)?", flags=re.MULTILINE)
test_str = ("( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand $ details $ role ) )\n\n"
"( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )\n\n"
"( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code $ name ) )\n\n"
"( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code $ name ) MAY ( group $ description ) )\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")