const regex = /MUST\s+(?:\(([^()]+)\)|(\S+))\s*(?:MAY)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MUST\\s+(?:\\(([^()]+)\\)|(\\S+))\\s*(?:MAY)?', 'gm')
const str = `( class1-OID NAME 'class1' SUP top STRUCTURAL MUST description MAY ( brand \$ details \$ role ) )
( class2-OID NAME 'class2' SUP top STRUCTURAL MUST groupname MAY description )
( class3-OID NAME 'class3' SUP top STRUCTURAL MUST ( code \$ name ) )
( class4-OID NAME 'class4' SUP top STRUCTURAL MUST ( code \$ name ) MAY ( group \$ description ) )
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}