#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<strike_all> # strikethrough can be multilines" & @CRLF & _
" (?<!\\)\~{2} # Start with 2 tilde" & @CRLF & _
" (?!\n) # but not followed by a new line to avoid any previous tildes getting caught" & @CRLF & _
" (?<strike_content> # the content which excludes any tilde unless they are escaped" & @CRLF & _
" (?>\\[\~]|[^\~])*+" & @CRLF & _
" )" & @CRLF & _
" (?<!\\)\~{2} # terminated by 2 tildes" & @CRLF & _
")"
Local $sString = "~~Hi~~ Hello, world!" & @CRLF & _
"" & @CRLF & _
"~~This whole sentence is wrong~~" & @CRLF & _
"" & @CRLF & _
"No ~ allowed unless it is escaped" & @CRLF & _
"" & @CRLF & _
"~~Not ok unless ~ is escaped~~" & @CRLF & _
"" & @CRLF & _
"~~Not ok unless \~ is escaped~~" & @CRLF & _
"" & @CRLF & _
"Another example: ~~ New " & @CRLF & _
"line is permitted~~" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")