const regex = /(?<strike_all> # strikethrough can be multilines
(?<!\\)\~{2} # Start with 2 tilde
(?!\n) # but not followed by a new line to avoid any previous tildes getting caught
(?<strike_content> # the content which excludes any tilde unless they are escaped
(?>\\[\~]|[^\~])*+
)
(?<!\\)\~{2} # terminated by 2 tildes
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<strike_all> # strikethrough can be multilines
(?<!\\\\)\\~{2} # Start with 2 tilde
(?!\\n) # but not followed by a new line to avoid any previous tildes getting caught
(?<strike_content> # the content which excludes any tilde unless they are escaped
(?>\\\\[\\~]|[^\\~])*+
)
(?<!\\\\)\\~{2} # terminated by 2 tildes
)', 'gm')
const str = `~~Hi~~ Hello, world!
~~This whole sentence is wrong~~
No ~ allowed unless it is escaped
~~Not ok unless ~ is escaped~~
~~Not ok unless \\~ is escaped~~
Another example: ~~ New
line is permitted~~
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}