import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<strike_all> # strikethrough can be multilines\n"
+ " (?<!\\\\)\\~{2} # Start with 2 tilde\n"
+ " (?!\\n) # but not followed by a new line to avoid any previous tildes getting caught\n"
+ " (?<strike_content> # the content which excludes any tilde unless they are escaped\n"
+ " (?>\\\\[\\~]|[^\\~])*+\n"
+ " )\n"
+ " (?<!\\\\)\\~{2} # terminated by 2 tildes\n"
+ ")";
final String string = "~~Hi~~ Hello, world!\n\n"
+ "~~This whole sentence is wrong~~\n\n"
+ "No ~ allowed unless it is escaped\n\n"
+ "~~Not ok unless ~ is escaped~~\n\n"
+ "~~Not ok unless \\~ is escaped~~\n\n"
+ "Another example: ~~ New \n"
+ "line is permitted~~\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}