import Foundation
let pattern = ##"""
(?<strike_all> # strikethrough can be multilines
(?<!\\)\~{2} # Start with 2 tilde
(?!\n) # but not followed by a new line to avoid any previous tildes getting caught
(?<strike_content> # the content which excludes any tilde unless they are escaped
(?>\\[\~]|[^\~])*+
)
(?<!\\)\~{2} # terminated by 2 tildes
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
~~Hi~~ Hello, world!
~~This whole sentence is wrong~~
No ~ allowed unless it is escaped
~~Not ok unless ~ is escaped~~
~~Not ok unless \~ is escaped~~
Another example: ~~ New
line is permitted~~
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)