using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<strike_all> # strikethrough can be multilines
(?<!\\)\~{2} # Start with 2 tilde
(?!\n) # but not followed by a new line to avoid any previous tildes getting caught
(?<strike_content> # the content which excludes any tilde unless they are escaped
(?>\\[\~]|[^\~])*+
)
(?<!\\)\~{2} # terminated by 2 tildes
)";
string input = @"~~Hi~~ Hello, world!
~~This whole sentence is wrong~~
No ~ allowed unless it is escaped
~~Not ok unless ~ is escaped~~
~~Not ok unless \~ is escaped~~
Another example: ~~ New
line is permitted~~
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}