package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(= \(\[interpret\] \s*\(query \(\[i_query\] \(\(name\)([\s\S]*)\)`)
var str = `(= ([interpret]
(query ([i_query] ((name)
(argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category $item12)))
(argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category $item24))))))))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}