import Foundation
let pattern = #"\(= \(\[interpret\] \s*\(query \(\[i_query\] \(\(name\)([\s\S]*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(= ([interpret]
(query ([i_query] ((name)
(argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category $item12)))
(argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category $item24))))))))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)