re = /\(= \(\[interpret\] \s*\(query \(\[i_query\] \(\(name\)([\s\S]*)\)/m
str = '(= ([interpret]
(query ([i_query] ((name)
(argument ((name item1) (eval (.Eval 0)) (.Span 0) (.Category $item12)))
(argument ((name item2) (eval (.Eval 1)) (.Span 1) (.Category $item24))))))))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end