using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)text";
string substitution = @"${1}bar";
string input = @"text abcd text text efgh";
RegexOptions options = RegexOptions.Singleline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}