$re = '~(.*)text~su';
$str = 'text abcd text text efgh';
$subst = "${1}bar";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;