package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.*)text`)
var str = `text abcd text text efgh`
var substitution = "${1}bar"
fmt.Println(re.ReplaceAllString(str, substitution))
}