// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?su)(.*)text").unwrap();
let string = "text abcd text text efgh";
let substitution = "${1}bar";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}